Algoritmos – Exercícios

1-     Escreva um algoritmo que leia três valores do teclado e imprima estes valores em ordem crescente.

Algoritmo

Declare num1, num2, num3 numérico

Escreva “Digite o primeiro número:”

Leia num1

Escreva “Digite o segundo número:”

Leia num2

Escreva ”Digite o terceiro número:”

Leia num3

Se num1 < num2 E num 1 < num 3

ENTÃO SE num2 < num 3

ENTÃO ESCREVA “A ordem crescente é:”, num1, “_”, num2 “_”, num3

SE NÃO ESCREVA “A ordem crescente é: “, num1, “_”, num3, “_”, num2 SE num 2 < num 1 E num 2 < num 3

ENTÃO SE num 1 < num 3

ENTÃO ESCREVA “ A ordem crescente é: “, num 2, “_”, num1, “_”, num3

SE NÃO ESCREVA “A ordem crescente é: “, num2, “_”, num3, “_”num1 SE num 3 < num 1 E num 3 < num 2 num 1 < num 2

ENTÃO ESCREVA “ A ordem crescente é : “, num3, “_”, num 1, “_”, num 2

SE NÃO ESCREVA “ A ordem crescente é : “, num 3, “_”, num 2, “_”, num1

FIM_ALGORITMO

 

2-     Reescreva o exercício anterior de forma que os valores sejam impressos na ordem decrescente.

 

Algoritmo

Declare num1, num2, num3 númerico

Escreva “Digite o primeiro número:”

Leia num1

Escreva “Digite o segundo número:”

Leia num2

Escreva ”Digite o terceiro número:”

Leia num3

Se num1 > num2 E num 1 > num 3

ENTÃO SE num2 > num 3

ENTÃO ESCREVA “A ordem decrescente é: “, num1, “_”, num2 “_”, num3

SE NÃO ESCREVA “A ordem decrescente é: “, num1, “_”, num3, “_”, num2 SE num 2 > num 1 E num 2 > num 3

ENTÃO SE num 1 > num 3

ENTÃO ESCREVA “ A ordem decrescente é: “, num 2, “_”, num1, “_”, num3

SE NÃO ESCREVA “A ordem decrescente é: “, num2, “_”, num3, “_”num1 SE num 3 > num 1 E num 3 > num 2 num 1 > num 2

ENTÃO ESCREVA “ A ordem decrescente é : “, num3, “_”, num 1, “_”, num 2

SE NÃO ESCREVA “ A ordem decrescente é : “, num 3, “_”, num 2, “_”, num1

FIM_ALGORITMO

 

3-     Faça um algoritmo que receba do usuário o nome e o salário bruto de um professor e retorne o seu nome seguido do salário líquido de acordo com a seguinte regra:

a)      Descontar 8% caso o salário seja menor que R$ 500,00.

b)      Descontar 14% caso o salário esteja entre R$ 500,00 a R$ 2.500,00.

c)      Descontar 29% para salários acima de R$ 2.500,00.

Atenção!

8% pode ser possível pela multiplicação do salário por 0,08, pois 8%= 8/100-0,08

 

ALGORITMO

DECLARE  salário, desconto, novo_sal, nome_prof   NUMÉRICO

ESCREVA “Digite o nome do professor ( 1,2,3,4,_,)”

LEIA nome professor

ESCREVA”Digite o valor do salário:  “

LEIA salário

SE professor “_” salário > ] 2.500,00 * 29/100

desconto ? salário “_” 29/100

ENTÃO ESCREVA “o valor do desconto é:  “, desconto

novo_sal ? salário – desconto

ESCREVA “o novo salário é :  “, novo salário

FIM

SE NÃO ESCREVA “Digite o nome do professor ( 1,2,3,4,_,)”

LEIA nome professor

ENTÃO ESCREVA”Digite o valor do salário:  “

LEIA salário

SE professor “_” salário > = 500,00  E  sal < = 2.500,00 * 14/100

desconto ? salário “_” 14/100

ESCREVA “o valor do desconto é:  “, desconto

novo_sal ? salário – desconto

ENTÃO ESCREVA “o novo salário é :  “, novo salário

FIM

SE NÃO ESCREVA “Digite o nome do professor ( 1,2,3,4,_,)”

LEIA nome professor

ESCREVA”Digite o valor do salário:  “

LEIA salário

SE professor “_” salário <  ] 500,00  * 0,08

desconto ? salário “_” 0,08

ESCREVA “o valor do desconto é:  “, desconto

novo_sal ? salário – desconto

ENTÃO ESCREVA “o novo salário é :  “, novo salário

FIM

FIM_ALGORITMO.

 

4-     Nesta atividade, você auxiliará um professor do ensino médio a trabalhar com figuras geométricas com seus alunos. Para tanto, faça um algoritmo que receba do usuário três valores (medidas) e retorne  “As medidas formam um triângulo” ou “As medidas não formam um triângulo. Além disso se as medidas digitadas formarem, um triângulo, informe se o triângulo é isósceles, Escaleno ou Equilátero. Considere:

– Isósceles: dois lados iguais e um diferente.

– Escaleno: possui todos os lados diferentes.

– Equilátero: possui todos os lados iguais.

 

ALGORITMO

DECLARE x, y, z NUMÉRICO

LEIA x,y,z

SE x < y + z E y < x + z E z < x + y

ENTÃO ESCREVA “Triângulo”

ENTÃO INICIO

SE x = y E y = z

ENTÃO ESCREVA “Triangulo Equilátero

SE NÃO SE x = y OU x = z

ENTÃO ESCREVA “Triângulo Isósceles”

SE NÃO SE x ? y E x ? z E y ? z

ENTÃO ESCREVA “Triângulo Escaleno”

FIM

SE NÃO ESCREVA “ Essas medidas não formam um triângulo”

FIM_ALGORITMO

 

Exercícios Complementares

 

1-     Faça um algoritmo que auxilie um professor na aula da disciplina de Língua Portuguesa. O algoritmo deverá receber uma letra do teclado, digitada pelo aluno, e avaliar se essa letra é uma vogal, escrevendo o resultado na tela.

Considere a possibilidade de receber a letra em maiúsculo ou minúsculo. Se o caractere digitado não for uma letra, informe que o aluno digitou uma letra inválida, ou seja, não faz parte do alfabeto.

 

 

ALGORITMO

DECLARE A,E,I,O,U ou a,e,i,o,u

LEIA VOGAL

ESCREVA (“entre com uma tecla”)

LEIA (A,E,I,O,U ou a,e,i,o,u)

SE NÂO “_”

LEIA “_”

ENTÃO ESCREVA “Letra inválida”

FIM_ALGORITMO

2-     Faça um algoritmo que leia dois valores e escreva na tela a diferença entre o maior e menor valor. Desconsidere a possibilidade de serem iguais.

 

ALGORITMO

DECLARE num1, num2  NÚMERICO

ESCREVA “Digite o primeiro número”

LEIA num1

ESCREVA “Digite o segundo número

LEIA num2

SE num1 >, num2

ENTÃO ESCREVA “A diferença num1 E num2

SE num2 > num1

ENTÃO ESCREVA “A diferença num2, num1

SE num1 = num2

ENTÃO ESCREVA “inválido”

SE num2 = num1

ENTÃO ESCREVA “invalido”

FIM_ALGORITMO

 

EXERCÍCIO 3 =1

EXERCÍCIO 4 =2